Support unavailable (chat & mail)
Incident Report for Officient
Resolved
The support chat and e-mail are available again!
Posted Jan 17, 2020 - 16:35 CET
Investigating
Our service provider Intercom is down, you can follow this on https://www.intercomstatus.com/. We are monitoring the situation closely.
This has no impact on the workings of Officient, only the support chat and e-mail service.
Posted Jan 17, 2020 - 15:54 CET
This incident affected: Officient HR admin application.