Officient Self Service unavailable in iPhone App Store
Incident Report for Officient
Resolved
The Self Service app is available in the iPhone app store again.
Posted Jan 29, 2024 - 11:26 CET
Investigating
The Officient Self Service app is currently not available in the iPhone App Store. iPhone users that already have the app installed will not be affected.
Posted Jan 26, 2024 - 19:55 CET
This incident affected: Officient employee self-service.