Unstable email service
Incident Report for Officient
Resolved
This issue has been resolved. All emails should come through.
Posted Jan 26, 2024 - 19:47 CET
Identified
We have identified the issue and looking into a fix.
Posted Jan 24, 2024 - 11:12 CET
Investigating
Some emails triggered from the HR platform might not get delivered, our team is currently investigating the issue.
Posted Jan 22, 2024 - 16:18 CET
This incident affected: Officient HR admin application.